Node Dependencies

最近又在改版 m.icrt (opens new window)

距離第一個版本也有半年的時間了,上次 2.0 改版 (opens new window) 時沒有升級 dependencies 。

所以這次改版目標就是把一些 framework 拉到新一點的版本。

但是一個一個查版本實在有些費力,Google 發現 FogCreek/node-dependencies (opens new window) 這個小工具可以很方便地來檢查 dependencies。

下面就是安裝的步驟以及執行的結果

{% codeblock lang:bash %} npm install -g node-dependencies onlinemad:~/node-dependencies Package Local Major Minor Patch any-db 1.0.0-rc2 2.1.0 --- 1.0.3 any-db-postgres 1.0.0-rc2 2.1.1 --- 1.0.2 connect-memcached 0.0.3 --- --- 0.0.6 aws-lib 0.2.1 --- 0.3.0 --- cheerio 0.11.0 --- 0.13.1 --- commander 1.1.1 2.1.0 1.3.2 --- express 3.2.6 --- 3.4.8 --- grunt-concurrent 0.3.1 --- 0.4.3 --- grunt-contrib-jade 0.8.0 --- 0.9.1 --- grunt-contrib-uglify 0.2.7 --- 0.3.1 --- grunt-nodemon 0.1.2 --- 0.2.0 --- i18next 1.6.8 --- 1.7.1 --- jade 0.30.0 1.1.5 0.35.0 --- mocha 1.9.0 --- 1.17.0 --- request 2.21.0 --- 2.33.0 --- sql 0.31.0 --- 0.35.0 --- stylus 0.32.1 --- 0.42.1 --- async 0.2.9 --- --- --- grunt 0.4.2 --- --- --- grunt-contrib-cssmin 0.7.0 --- --- --- grunt-contrib-watch 0.5.3 --- --- --- iconv-lite 0.2.11 --- --- --- matchdep 0.3.0 --- --- --- {% endcodeblock %}

其實結果會有顏色,不過 blog 沒辦法上色 XD

看完報告後就是漫長的升級之路了...

BTW 好用的小工具,推薦給大家